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CAUTION notice until the indicated 
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A WARNING notice denotes a 
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Trademarks
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Installation Guides
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have understood all the applicable 
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Where to find more information
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for assistance on the following link:

http://www.http/agilent/find/assist



Safety Symbols on Instruments
ASI Exerciser & Analyzer User Guide
Indicates warning or caution. If you 
see this symbol on a product, you 
must refer to the manuals for 
specific Warning or Caution 
information to avoid personal injury 
or damage to the product.

Frame or chassis ground terminal. 
Typically connects to the 
equipment’s metal frame.

Indicates hazardous voltages and 
potential for electrical shock.
Indicates that antistatic 
precautions should be taken.

Indicates hot surface. Please do 
not touch.

Indicates laser radiation turned on.

Safety requirements for electrical 
equipment for measurement, 
control, and laboratory use 
CAN/CSA C22.2 No. 1010.1 (1993) 
UL 3101, 3111 (First Editions) This 
equipment has also been evaluated 
to IEC 61010 edition 1 including 
amendments 1 and 2.
Notice for European Community: 
This product complies with the 
relevant European legal Directives: 
EMC Directive 89/336/EEC and 
Low Voltage Directive 73/23/EEC.

This is the symbol for an Industrial, 
Scientific, and Medical Group 1 
Class A product.
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This chapter introduces you to the Advanced Switching 
Interconnect (ASI) protocol and provides a brief overview of 
its architecture. This chapter also introduces you to the 
E2980 series that provides a test and measurement solution 
for the ASI protocol.
7Agilent Technologies



1 Introduction
About ASI
8

ASI is a packet- based transaction layer protocol that makes 
use of the physical and data link layers of PCI Express. The 
objective of the ASI protocol is to provide a native 
interconnect solution for multi- host, peer- to- peer 
communications without any additional bridges or media 
access control. This protocol is the only interconnect 
technology used for both chip- to- chip and backplane 
applications to minimize the overall system costs and 
interconnect latencies.

ASI provides a rich set of features to its users. Some such 
features are: 

• Enhanced packet routing 

• Congestion management

• Support for multicast

• Fabric redundancy and fail over mechanisms

• Protocol encapsulation

• Simple load and store

• Simple queuing of data packets

• Secure data transportation
ASI Exerciser & Analyzer User Guide
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Understanding the ASI Architecture
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Figure 1 displays the layered architecture of ASI.

Figure 1 ASI Architecture

Figure 1 shows data transfer between ASI layers: 
Transaction, Data Link, and Physical. It also shows that data 
transfer between ASI layers take place in the following 
phases: 

• Transmit

• Receive

In the transmit phase:

1 A data packet is formed in the transaction layer and 
transmitted to the data link layer.

2 In the data link layer, information to check data packets 
errors at the receiving device is added to the data packet. 
The data packet is then transferred to the physical layer.

Link
9
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3 In the physical layer, the data packet is encoded. Then, it 
is transmitted on the link by the analog portion of the 
physical layer. From there, it is transmitted to the 
receiving device using the available lanes of the link.

In the receive phase:

1 The receiver device decodes the incoming the data packet 
in the physical layer and forwards the resulting contents 
to the data link layer.

2 The data link layer checks for error in the incoming data 
packet. If there are no errors, it forwards the data packet 
up to the transaction layer.

3 The transaction layer buffers the incoming data packet 
and convert it to a format that the device core and ASI 
core logic interface understand.
ASI Exerciser & Analyzer User Guide
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About the E2980 Series
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To thoroughly test your ASI systems and devices, you need 
to create system conditions that are difficult to reproduce 
with existing ASI equipment. The Protocol Exerciser and 
Analyzer applications of the E2980 series enable you to 
quickly and easily simulate traffic or capture traffic 
conditions and recreate them.

This section includes the following topics:

• E2980 Series Architecture

• Protocol Exerciser for ASI

• Protocol Analyzer for ASI
E2980 Series Architecture
Figure 2 displays the architecture of the E2980 series.

Figure 2 E2980 Architecture

In E2980, the Protocol Exerciser and Protocol Analyzer 
applications utilize the general hardware and software 
architecture of the Serial Protocol Tester platform. 
11
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In E2980, a system controller (PC) is connected to one or 
more chassis through LAN. You can also connect multiple 
chassis using special cables to form a synchronized, 
multi- port measurement system. Each chassis can hold two 
or four independent I/O modules. 

An I/O module contains a CPU daughter board, the main 
FPGA logic, and memories for the functionality of Protocol 
Exerciser and Analyzer. Also, each I/O module handles 
exactly one ASI link up to 8x link width.

A list of the components of the E2980 platform is given 
below:

• Chassis (2 slot or 4 slot)

• I/O Module

• Probe Board (PCIe Slot/Interposer, ATCA active/passive, 
or Midbus probe)

• Protocol Exerciser and/or Analyzer software packages

• PC connected with the chassis via 100 Mbit LAN to 
control the system.
Protocol Exerciser for ASI

NOTE PC and LAN interface are not included in the shipment of the E2980 
platform. You have to purchase them separately from your preferred 
vendor.

NOTE For more information on hardware set up, refer to the System Protocol 
Tester Installation Guide.
Protocol Exerciser for ASI enables you to generate and 
respond to all types of ASI transactions. For example, it 
enables you to emulate any ASI device and topology, 
generate ASI packets, and respond to any ASI packet. You 
can also use it to emulate stress conditions for components 
on system boards and cards. 

A brief list of the capabilities and benefits of the Protocol 
Exerciser application is given below:

• Enables you to perform worst- case- scenario tests.

• Provides flexible control to set up basic ASI packets 
quickly and easily.

• Enables you to easily simulate the Transaction layer and 
test the Data Link layer capabilities of an ASI device.
ASI Exerciser & Analyzer User Guide
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• Ensures inter- operability and stability of all data paths 
and gets largest possible test coverage with links to root 
cause analysis of problems.

• Enables you develop a test design according to the 
specification.

• Enables you to view and edit the to- be- transmitted ASI 
packets, decode and display the received and transmitted 
ASI packets, and display and edit the capabilities of an 
emulated device easily.

• Enables you to perform realistic tests with device 
emulation. This helps minimize the number of real devices 
needed to create a large- scale test environment.

• Increases test coverage with configurable traffic 
generation.

• Provides real- time statistics to help you view immediate 
changes in the system performance.

• Enables you to customize your measurements with test 
automation and scripting capabilities.

With these capabilities and benefits, you can use Protocol 
Exerciser to efficiently test and validate the x1, x2, x3, x4, 
and x8 ASI designs.
Protocol Analyzer for ASI

NOTE Protocol Exerciser for ASI has two interfaces: GUI and API. This guide 
covers only the GUI aspect of the Protocol Exerciser application. For 
information on API, please refer to the online help.
Protocol Analyzer for ASI enables you to capture the traffic 
or transactions on a ASI link, and analyze and troubleshoot 
the problems to find the root cause. It captures and analyzes 
the Data Link layer and Transaction layer packets, training 
sequences, and ordered sets. It also provides non- intrusive 
monitoring of traffic between two ASI nodes. 

A brief list of the capabilities and benefits of the Protocol 
Analyzer application is given below:

• Provides easy visibility into ASI transactions. For this, it 
displays the traffic activity, port link status, and trace 
content simultaneously. It also provides sophisticated and 
fast screen based traffic upload.

• Provides a trigger sequencer with sophisticated trigger 
capabilities.
13
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• Provides tabular traffic display that speeds the debug 
process.

• Provides multi- port display for better insight into your 
system.

• Provides powerful search, filter, and error detection 
functionality.

• Enables you to customize your measurements with test 
automation and scripting capabilities.

With these capabilities in analyzing generated ASI traffic, 
Protocol Analyzer is perfectly suited for debugging the ASI 
systems and designs.
NOTE Protocol Analyzer for ASI has two interfaces: GUI and API. This guide 
covers only the GUI aspect of the Protocol Analyzer application. For 
information on API, please refer to the online help.
ASI Exerciser & Analyzer User Guide
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This chapter introduces you the method of accessing the 
Protocol Exerciser application. This chapter also introduces 
you to the various GUI components of the Protocol Exerciser 
application.
15Agilent Technologies
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About Protocol Exerciser
16
The Protocol Exerciser application enables you to send and 
receive TLP packets, and control various protocol variations 
and violations over ASI. Using this application, you can 
generate and insert errors on different ASI layers.
Accessing Protocol Exerciser
Before you get started with Protocol Exerciser, you need to 
know how to access it. Accessing Protocol Exerciser requires 
you to specify whether you want to connect to a new or an 
existing session, and the name of the server where you want 
to start the session. Accessing Protocol Exerciser also 
requires you to specify the port to use if you are trying to 
connect to a new session.

To specify all required inputs, Protocol Exerciser provides 
two dialog boxes: Select type of connection (Figure 3) and 
Select port to use (Figure 4).

Table 1 briefly describes the components of the Select type 
of connection dialog box.

Figure 3 Select type of connection dialog box
ASI Exerciser & Analyzer User Guide
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Table 1 Components of the Select type of connection dialog box 

Component Description

Connect to existing session Select Connect to existing session if you want to 
use an existing session of Protocol Exerciser on a 
known server.

Connect to new session Select Connect to new session if you want to 
create a new Protocol Exerciser session on a 
known server.

Offline mode Select Offline mode if you want to work in off-line 
mode. Working in off-line mode does not connect 
you to the hardware.

Server Specifies the name or IP address of the server, 
where you want to start a new or join an existing 
Protocol Exerciser session. Its default value is 
localhost. Also, this text field is disabled if you 
have selected the Offline mode option.

Get session list Click Get session list to retrieve a list of existing 
Protocol Exerciser sessions from the server you 
specified in the Server text field. This button 
works only if you have selected the Connect to 
existing session option. 

Session list Displays a list of sessions existing on the server 
you specified in the Server text field.

Start Click Start to log on to the Protocol Exerciser 
application.

Exit Click Exit to close the dialog box without starting 
the Protocol Exerciser application.

Help Click Help to display the online help.
17
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2 Getting Started With Protocol Exerciser
Figure 4 displays the Select Port to use dialog box.
Figure 4 Select Port to use dialog box
Table 2 briefly describes the components of the Select port 
to use dialog box.

To access Protocol Exerciser

1 On the Windows task bar, click Start > Programs > 
Agilent System Protocol Tester > Exerciser for ASI.

The Select type of connection dialog box appears.

Table 2 Components of the Select port to use dialog box 

Component Description

Module/Port Provides a check box list of modules and its ports. Here, select 
a module or a port to start a new Protocol Exerciser session.

State Displays the current state of the ports, e.g., ready, rebooting, or 
in use by session.

Type Provides a drop-down list of type of modules. Here, selecting a 
module displays the names of its ports, below the drop-down 
list.

Description Displays the description of the selected module or port.

IP Displays the IP address of the selected port.

OK Click OK to start an instance of Protocol Exerciser on the 
selected port.

Refresh list Click Refresh list to refresh the content shown in the Port list 
box.
ASI Exerciser & Analyzer User Guide
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2 Do one of the following:

a Click Connect to existing session to use an existing 
Protocol Exerciser session.

b Click Connect to new session to start a new Protocol 
Exerciser session.

c Click Offline mode to access Protocol Exerciser 
without connecting to the hardware.

3 Type in the name or IP address of the server, where you 
want to start a new or join an existing Protocol Exerciser 
session, in the Server text field.

4 If you are trying to use an existing Protocol Exerciser 
session, do the following:

a Click Get session list. A list of sessions currently 
running on the server specified in the Server text field 
is displayed in Session list.

b Select the required session from Session list.

c Click Start. The main Protocol Exerciser window 
appears.

5 If you are trying to create a new Protocol Exerciser 
session, do the following:

a Click Start. The Select port to use dialog box appears.

b Select a module or port check box from the 
Module/Port column.

c Select a module name from the corresponding Type 
column.

d Click OK. The main Protocol Exerciser window 
appears.
Exiting Protocol Exerciser
You can exit from the Protocol Exerciser application by 
closing the current sessions and the Protocol Exerciser 
window.

To close a Protocol Exerciser session

1 Select the Protocol Exerciser session, which you want to 
close, from the <Setup_Filename> pane. 

For information on the <Setup_Filename> pane, refer to 
Using Panes on page 25.

2 Click File > Close.
19
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NOTE If there is only one Protocol Exerciser session, then you do not have to 
select it to close it.

NOTE For more information on the <Setup_Filename> pane, refer to Navigation 
on page 25.
20
To exit Protocol Exerciser

1 Click File > Exit.

If no other GUI instance is connected to this session, the 
Closing Session message box appears.

2 Do one of the following:

a Click Yes. This closes the Protocol Exerciser window 
and also removes the associated session.

b Click No. This closes the Protocol Exerciser window 
without removing its associated session. To again 
connect to this session, refer to To access Protocol 
Exerciser on page 18.
ASI Exerciser & Analyzer User Guide
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About the Protocol Exerciser Components
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Protocol Exerciser provides various components that you can 
use to access its various features.

Figure 5 displays the Protocol Exerciser application window 
with its main components.
Figure 5 Protocol Exerciser window
This section covers the following topics:

• Using the Menu Bar

• Using the Toolbar

• Using Panes
21
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Using the Menu Bar
22
The Menu Bar is one way to access the functionality of the 
application. In Protocol Exerciser, menu bar provides the 
following menus:

• File menu

• Edit menu

• View menu

• Action menu

• Help menu

File menu

Table 3 provides a brief description of the File menu 
commands.

Table 3 File menu commands 

Menu command Description

New Creates a new setup file of the Exerciser template.

Open Displays the Open dialog box that enables you to open 
the saved session information.

Save Displays the Save dialog box that enables you to save 
the session information. If you are saving it for the first 
time, then this menu command saves the session 
information at the default location. Otherwise, this 
menu command saves it on the last saved location.

Save As Displays the Save As dialog box that enables you to 
specify the desired location to save the session 
information.

Close Closes the selected session.

Import Displays the Import dialog box that you use to import 
the saved data packets.

Export Displays the Export dialog box that you use to save the 
data packets to be send.

Software Packages Displays the Software Package Management dialog 
box that shows you the already installed software and 
provides a list of new software to be installed.

Exit Closes the Protocol Exerciser application.
ASI Exerciser & Analyzer User Guide



Getting Started With Protocol Exerciser 2

ASI Exerciser & Analyzer User Guide
Edit menu

Table 4 provides a brief description of the Edit menu 
commands.

View menu

Table 5 provides a brief description of the View menu 
commands.

Action menu

Table 6 provides a brief description of the Action menu 
commands.

Table 4 Edit menu commands 

Menu command Description

Copy Copies single packets, block transfers, or completions 
to the clipboard.

Paste Pastes the clipboard data. You can also use this 
command to paste data from Protocol Analyzer.

Table 5 View menu commands 

Menu command Description

Navigation Window Displays the Navigation pane.

Hardware Status Window Displays the Hardware Status pane.

Preferences Displays the Preferences dialog box.

Arrange Tabs Vertically Arranges the tabs of the current window, vertically.

Arrange Tabs Horizontally Arranges the tabs of the current window, 
horizontally.

Arrange Tabs In One 
Group

Groups the tabs of the current window.

Reset View Resets the tabs of the current window to their 
default view.

Table 6 Action menu commands 

Menu command Description

Link Up Starts link training.

Run Starts sending packets (single or block transfer).

Stop Stops sending packets.
23
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Help menu

Table 7 provides a brief description of the Help menu 
commands.

Table 7 Help menu commands 

Menu command Description

Online Help Displays the online help for Protocol Exerciser.

Session Information Displays the Session Information message box with 
the current session information.

Version Information Displays the version information of the Protocol 
Exerciser application.

About Displays information about the System Protocol 
Tester platform.
Using the Toolbar
Toolbar provides a quick access to the features of the 
Protocol Exerciser application (Figure 6).

Table 8 specifies the names of all toolbar icons.

Figure 6 Toolbar

Table 8 Toolbar icons

Icon Name

New

Open

Save

Navigation Window

Link Up

Run Exerciser
ASI Exerciser & Analyzer User Guide
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Stop Exerciser

Send All

Send Selected

Receive DLLP

Table 8 Toolbar icons

Icon Name
Using Panes
Protocol Exerciser provides the following panes:

• Navigation

• Hardware Status
NOTE These two panes are flowing components. To move these panes to a new 
location on the screen, select them from their titles and drag them to the 
new location. Double-click on their title to place them back to their default 
location.
Navigation

The Navigation pane further provides the following panes:

• Exerciser: This pane enables you to navigate between 
multiple setup files.

• <Setup_Filename>: Setup_Filename refers to the name of 
the setup file, e.g., Test_02. This pane provides options 
to use Protocol Exerciser for your test application.
25
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Figure 7 displays the Navigation pane.

Hardware Status

The Hardware Status pane has the following tabs: 

• Status: This tab provides the status information of the 
link width, link state, receiver’s (Rx) priority reversal, and 
transmit memories.

• Flow Control: This tab provides information about the 
credits of the transmit memories.

• VC Status: This tab provides information about which 
traffic class is mapped to which Tx Memory.

Figure 7 Navigation pane
ASI Exerciser & Analyzer User Guide
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Figure 8 displays the Hardware Status pane.

Figure 8 Hardware Status pane
27
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This chapter introduces you the method of accessing the 
Protocol Analyzer application. This chapter also introduces 
you to the various GUI components of the Protocol Analyzer 
application.
29Agilent Technologies
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About Protocol Analyzer
30
The Protocol Analyzer application enables you to capture 
and analyze traffic between two ASI nodes. Using Protocol 
Analyzer, you can capture data packets simultaneously from 
both directions. This includes capturing training sequences, 
Data Link Layer Packets (DLLPs), and Transaction Layer 
Packets (TLPs). 

To capture data packets, Protocol Analyzer provides a trigger 
sequencer, which you use to specify the criteria to capture 
the data packets. 
Accessing Protocol Analyzer
Before you get started with Protocol Analyzer, you need to 
know how to access it. Accessing Protocol Analyzer requires 
you to specify whether you want to connect to a new or an 
existing session, and the name of the server where you want 
to start the session. Accessing Protocol Analyzer also 
requires you to specify the port to use if you are trying to 
connect to a new session.

To specify all required inputs, Protocol Exerciser provides 
two dialog boxes: Select type of connection (Figure 9) and 
Port Selection (Figure 10).

Figure 9 Select type of connection dialog box
ASI Exerciser & Analyzer User Guide



Getting Started With Protocol Analyzer 3

ASI Exerciser & Analyzer User Guide
Table 9 briefly describes the components of the Select type 
of connection dialog box.

Table 9 Components of the Select type of connection dialog box

Component Description

Connect to existing 
session

Select Connect to existing session if you want to use 
an existing session of Protocol Analyzer on a known 
server.

Connect to new 
session

Select Connect to new session if you want to create a 
new Protocol Analyzer session on a known server.

Server Specifies the name or IP address of the server, where 
you want to start a new or join an existing Protocol 
Analyzer session. Its default value is localhost.

Get session list Click Get session list to retrieve a list of existing 
Protocol Analyzer sessions from the server you 
specified in the Server text field. This button works 
only if you have selected the Connect to existing 
session option.

Session list Displays a list of sessions existing on the server you 
specified in the Server text field.

Start Click Start to log on to the Protocol Analyzer 
application.

Exit Click Exit to close the dialog box without starting the 
Protocol Analyzer application.

Help Click Help to display the online help.
31
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Figure 10 Port Selection dialog box
32
Table 10 briefly describes the components of the Port 
Selection dialog box.

Table 10 Components of the Port Selection dialog box

Component Description

Module Provides a chassis-wise check box list of modules.

Type Enables you to select the type of port, PCIe or ASI, to use.

# Ports Displays the number of ports for each module.

License Displays the license details of each module. 

Status Displays the status of each module.
ASI Exerciser & Analyzer User Guide
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Select Ports to use Select the port to use from the Select Ports to use list 
box.

OK Click OK to start an instance of Protocol Analyzer on the 
selected port.

Refresh List Click Refresh list to refresh the content shown in the 
Module and Port list boxes.

Table 10 Components of the Port Selection dialog box

Component Description
NOTE In the License column, the following text appears:

• PA-ASI-x1 or PA-ASI-x4 for Protocol Analyzer
• EX-ASI-x1 or EX-ASI-x4 for Protocol Exerciser
To access Protocol Analyzer

1 On the Windows task bar, click Start > Programs > 
Agilent System Protocol Tester > Protocol Analyzer.

The Select type of connection dialog box appears.

2 Do one of the followings:

a Click Connect to existing session to use an existing 
Protocol Analyzer session.

b Click Connect to new session to start a new Protocol 
Analyzer session.

3 Type in the name or IP address of the server, where you 
want to start a new or join an existing Protocol Analyzer 
session, in the Server text field.

4 If you are trying to use an existing Protocol Analyzer 
session, do the following:

a Click Get session list. A list of sessions that are 
currently running on the server specified in the Server 
text field is displayed in Session list.

b Select the required session from Session list.

c Click Start. The main Protocol Analyzer window 
appears.
33
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5 If you are trying to create a new Protocol Analyzer 
session, do the following:

a Click Start. The Port Selection dialog box appears.

b Select a module check box from the Module column.

c Select the option for ASI from the Type drop- down 
list.

d Click OK. The main Protocol Analyzer window appears.
Exiting Protocol Analyzer
You can exit from the Protocol Analyzer application by 
closing the opened trace file and the Protocol Analyzer 
window.

To close a trace file

• Click File > Close.

To exit Protocol Analyzer

1 Click File > Exit.

The Session still open message box appears.

2 Do one of the following:

a Click Yes. This closes the Protocol Analyzer window 
and also removes the associated session.

b Click No. This closes the Protocol Analyzer window 
without removing its associated session.
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Protocol Analyzer provides various components that you can 
use to access its various features.

Figure 11 displays the Protocol Analyzer application window 
with its main components.
Figure 11 Protocol Analyzer window
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This section covers the following topics:

• Using the Menu Bar

• Using the Toolbar
Using the Menu Bar
The Menu Bar is one way to access the functionality of the 
application. In the Protocol Analyzer application, menu bar 
provides the following menus:

• File menu

• Edit menu

• View menu

• Capture menu

• Help menu

File menu

Table 11 provides a brief description of the File menu 
commands.

Table 11 File menu commands

Menu command Description

Open Displays the Open dialog box that enables you to 
open a trace or XML file. 
A trace file is a .pad file that contains the trace data 
of a port. On the other hand, an XML file contains 
pointers to multiple trace files and contains other 
information, such as makers.

Save As Displays the Save As dialog box that enables you to 
save the trace to a file.

Close Enables you to close the session.

Page Setup Displays the Page Setup dialog box that enables you 
to specify the page settings for printing the trace.

Print Displays the Print dialog box that enables you to print 
the traced data.

Software Packages Displays the Software Package Management dialog 
box that shows you the already installed software 
and provides a list of new software to be installed. It 
not only displays licenses, but also allows you to add 
new licenses.

Exit Closes the Protocol Analyzer application.
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Edit menu

Table 12 provides a brief description of the Edit menu 
commands.

View menu

Table 13 provides a brief description of the View menu 
commands.

Table 12 Edit menu commands

Menu command Description

Copy Enables you to copy Analyzer data to clipboard. For 
example, you can copy one or more data packet records 
and paste them in Protocol Exerciser to generate same or 
similar type of data packets.

Find Displays the Find dialog box that enables you to specify 
the criteria to search data packets.

Find Previous Searches the previous occurrence of the data packet 
using the search criteria specified in the Find dialog box.

Find Next Searches the next occurrence of the data packet using 
the search criteria specified in the Find dialog box.

New Marker Creates a new marker at the beginning of a selected data 
packet or frame.

Delete Marker Removes the selected marker.

Marker Properties Displays the Properties of marker dialog box that you can 
use to view and modify the properties of a marker.

Table 13 View menu command

Menu command Description

Filter Provides sub-menu commands that enable you to create 
filters on data packets trace, as well as remove filters.

Goto Provides a sub-menu commands that enable you to move 
on to a trigger, marker, or a particular data packet record 
in the Packet Decode pane.

Zoom Enables you to set the screen resolution of the data 
packet records shown in the Packet Decode pane.

Expand All Packets Expands all the data packet records to show the details 
of their fields.

Collapse All Packets Collapses all the data packets records to hide the details 
of their fields.
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Capture menu

Table 14 provides a brief description of the Capture menu 
commands.

Capture

Help menu

Table 15 provides a brief description of the Help menu 
commands.

Record Decode 
View

Displays the Record Decode section that shows the 
hexadecimal representation of the fields of the selected 
data packet record in a tree-view format. In the Record 
Decode view, each element of the tree is a data packet 
field.

Single Line Decode 
View

Displays the Record Decode section that shows the 
hexadecimal representation of the fields of the selected 
data packet record in a contiguous manner.

Port Overview Displays the details of the port that is connected with the 
current Protocol Analyzer session.

Preferences Displays the Preferences dialog box.

Port Management Displays the Port Selection dialog box that enables you to 
select the ports of a module for your test application.

Default Window 
Arrangement

Resets the GUI settings of the Protocol Analyzer 
application to default.

Table 14 Capture menu commands

Menu commands Description

Start Starts capturing data packets.

Stop Stops capturing data packets.

Trigger Setup Displays the Trigger Setup dialog box.

Hardware Setup Displays the Hardware Setup pane.

Table 15 Help menu commands

Menu command Description

Help Topics Displays the online help for Protocol Analyzer.

Session 
Information

Displays the Session Information message box with the 
current session information.

Table 13 View menu command

Menu command Description
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About Displays the information about the System Protocol 
Tester system.

Table 15 Help menu commands

Menu command Description
Using the Toolbar
Toolbar provides a quick access to the features of the 
Protocol Analyzer application (Figure 12).

Figure 12 Toolbar

Table 16 specifies the names of all toolbar icons.

Table 16 Toolbar icons

Icon Name

Start hardware capturing

Stop hardware capturing

Show Trigger Setup

Show port setup

Open trace file

Save trace to file

Print

Print preview

Find packets
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Find previous occurrence

Fine next occurrence

Goto marker

Goto trigger

Filter packet display

Disable all packet filters

Zoom factor for packet views

Filter all Skip Ordered Sets

Filter all Update Flow control Packets and Skip 
Ordered Sets

Table 16 Toolbar icons

Icon Name
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This chapter provides you the information on how to use the 
Protocol Exerciser application for sending and receiving data 
packets. This chapter also provides information about editing 
data packets and their receive settings.
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Creating an ASI Link
42
Once you have created a new or connected to existing 
Exerciser session, the next step is to create an ASI link with 
the device under test (DUT). To do this, you need to specify 
the link settings in the Link Settings tab (Figure 13). 

Figure 13 Link Settings tab

Table 17 briefly describes the components of the Link 
Settings tab.

Table 17 Components of the Link Settings tab

Component Description

Supported Link 
Widths

Enables you to specify the desired link width to use for data 
transfer.
The x1 check box is selected by default.

Negotiated Link 
Width

Displays the link width that Protocol Exerciser and DUT have 
agreed upon after link up.
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Scrambler Provides Enabled and Disabled options to enable or disable 
the Scrambler algorithm.
Selecting Disabled disables the scrambling of data and also 
sets the Disable Scrambling bit in the link control field of 
training sequences during link training.
Selecting Enabled enables or disables scrambling of data 
depending on the state of the Disable Scrambling bit of the 
link partner during link training.
By default, scrambling is enabled.

Clock Source Enables you to specify the internal or external clock source. 
This only works with the PCI Express Probe Boards 
(E2938/39A and E2968A), when a clock is provided on the 
system connector (to System configuration) or the external 
clock in SMA connector (to DUT configuration).

Probe Board 
Mode

Enables you to specify mode of the probe board. It can be 
either To DUT or To System.

Table 17 Components of the Link Settings tab

Component Description
To create an ASI link
1 Click the General icon in the <Setup_Filename> pane.

2 Click the Link Settings tab.

3 Select x1, x2, x3, or x4 to specify the desired link width.

4 Select Enabled in the Scrambler drop- down list, if you 
want to scramble the data packets.

5 Select internal or external, as desired, from the Clock 
source drop- down list.

6 Select To DUT from the Probe Board Mode drop- down 
list to create a link between Protocol Exerciser and DUT.

Selecting this option works only if DUT is connected on 
the DUT connector of a PCIe or ATCA probe board.

7 Click Action > Link Up.

This creates a link between the Protocol Exerciser and 
DUT.
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Once you have created a link between Exerciser and DUT, 
you can start sending and receiving data packets.

This section covers the following topics:

• Sending and receiving data packets

• Editing data packets

• Modifying the settings for receiving data packets
Sending and receiving data packets
In Protocol Exerciser, you can send and receive data packets 
using the Send Packets (Figure 14) and Receive Packets 
(Figure 19) tabs. To access these tabs, click the Send / 
Receive Packets option from the <Setup_Filename> pane.

Figure 14 Send Packets tab

Table 18 briefly describes the components of the Send 
Packets tab.

Table 18 Components of the Send Packets tab

Component Description

Insert single packet 
above the selected 
packet

Click Insert single packet above the selected packet to 
insert a new data packet above the selected data packet. 
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To send and receive data packets

1 Select one of the Transmit Memory option buttons, Send 
TLP, or Send DLLP as required.

2 Click Insert single packet above the selected packet or 
Insert single packet below the selected packet.

The Select a Template dialog box appears (Figure 15).

Figure 15 Select a Template dialog box

3 Select the desired data packet template.

Insert single packet 
below the selected 
packet

Click Insert single packet below the selected packet to 
insert a new data packet below the selected data packet. 

Remove the 
selected packet

Click Remove the selected packet to remove the 
selected data packet.

Remove all the 
packets

Click Remove all the packets to remove all data packets.

Run Mode Provides the Continuous check box that you can select if 
you want to send data packets for infinite time. If this 
check box is not selected, then Protocol Exerciser sends 
the data packet only for once. 
By default, the Continuous check box is not selected. 
Also, this check box is not available for the Send TLP and 
Send DLLP options. 

Transmit Memory Provides a list of six transmit memories, Tx Mem 1 to Tx 
Mem 6. You can choose a transmit memory and add data 
packets to it. 

Send Single Provides options to send a single TLP or DLLP.

Table 18 Components of the Send Packets tab

Component Description
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4 Click OK.

This adds the new data packet in the Send Packets tab 
(Figure 16).

Figure 16 Send Packets tab with a data packet

5 Click Send Selected on the toolbar.

This transfers the selected data packet to the linked DUT.
Editing data packets
In addition to adding a data packet in the Send Packets tab, 
you can edit its default settings before sending it to the 
linked device. For this, Protocol Exerciser provides you the 
Edit Packet dialog box (Figure 17). The Edit Packet dialog 
box has two tabs: Packet Editor and Packet Behavior. In the 
Packet Editor tab, you can edit the contents of a data packet 
(Figure 17). In the Packet Behavior tab, you can edit the 
behavior of a data packet (Figure 18).
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To access the Edit Packet dialog box, double- click the data 
packet in the Send Packets tab.
Figure 17 Packet Editor tab
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Table 19 briefly describes the components of the Packet 
Editor tab.

Table 19 Components of the Packet Editor tab

Component Description

Field The Field column contains the names of the fields of a 
data packet. The number of fields displayed in this column 
may differ for different data packets.

Value The Value column contains an input component for each 
data field. You can specify the desired inputs in these 
components to edit the selected data packet. 
This column also contains a drop-down list and a 
calculator for input assistance. The drop-down list enables 
you to specify your inputs in hexadecimal, binary, or 
decimal format. 
Clicking the calculator for input assistance displays the 
Input Assistant dialog box. Here, you can perform boolean 
operations over the hexadecimal, binary, and decimal 
values, and use the resulting value as the new value for 
the corresponding data packet field.

Length The Length column displays the maximum length of a field 
in bits, bytes, or DWords.

Error The Error column displays an error message produced for 
the field due to illegal input value.

Length Specifies the length of the Payload data packet field in 
DWords. 

Apply Click Apply to assign the new length to the Payload data 
packet field.

OK Click OK to close the Edit Packet dialog box and save the 
the changes made to the data packet.

Cancel Click Cancel to close the Edit Packet dialog box without 
saving any changes.

Help Click Help to display the online help.
NOTE If you send a data packet whose payload is greater than 541 DW, then you 
need to link up again before sending another data packet.
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Figure 18 Packet Behavior tab
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Table 20 briefly describes the components of the Packet 
Behavior tab.

Table 20 Components of the Packet Behavior tab

Component Description

Field The Field column contains the names of the fields of a 
data packet. 

Value The Value column contains an input component for 
each data field. You can specify the desired inputs in 
these components to edit the selected data packet. 
This column also contains a drop-down list and a 
calculator for input assistance. The drop-down list 
enables you to specify your inputs in hexadecimal, 
binary, or decimal format. 
Clicking the calculator for input assistance displays the 
Input Assistant dialog box. Here, you can perform 
boolean operations over the hexadecimal, binary, and 
decimal values, and use the resulting value as the new 
value for the corresponding data packet field.

Length The Length column displays the maximum length of a 
field in bits, bytes, or DWords.

Error The Error column displays an error message produced 
for the field due to illegal input value.

OK Click OK to close the Edit Packet dialog box and save the 
the changes made to the data packet.

Cancel Click Cancel to close the Edit Packet dialog box without 
saving any changes.

Help Click Help to display the online help.
Modifying the settings for receiving data packets

NOTE In the Packet Behavior tab, if you specify the repeat count for a data 
packet as N, Protocol Exerciser repeats that data packet for N+1 times. For 
example, If you set the repeat count of data packet as 2, Protocol Exerciser 
repeats that data packet for 3 times.
The Receive Packets tab provides the following tabs that 
enable you to modify the settings for receiving data packets:

• TLP Receive: This tab enables you to specify the filter 
criteria for receiving TLPs. You can use this tab to receive 
or discard a particular type of TLPs.
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• DLLP Receive: This tab enables you to specify the filter 
criteria for receiving DLLPs. You can use this tab to 
receive or discard a particular type of DLLP.

• Receive Settings: This tab enables you to specify the 
maximum number of data packets that are kept in the 
Receive Packets window at a time. There may be a 
situation when there are more packets than the specified 
limit. In this case, older packets are first discarded to 
make room for the new incoming packets.

Figure 19 displays the TLP Receive tab.
Figure 19 Receive Packets tab
Table 21 briefly describes the components of the TLP 
Receive tab.

Table 21 Components of the TLP Receive tab

Component Description

Remove the selected 
packets

Click Remove the selected packets to remove the 
selected data packets from the buffer.

Remove all packets Click Remove all packets to delete all the selected 
data packets from the buffer.
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Pattern N Click Pattern N to display the Select a Template 
dialog box. Here, N is a digit ranging from one to four.
There is also a Default pattern. Data packets that do 
not fall into any pattern, by default fall into this 
pattern.

Discard Select Discard to prevent receiving the type of data 
packets you specified in the corresponding pattern.

Memory Select Memory to receive the type of data packets 
you specified in the corresponding pattern.

Data Analyzer Select Data Analyzer to compare packet payload 
against the algorithmically generated data. This 
works only for the PI-8 (Memory Write) packets, 
where the destination memory address determines 
the data to be generated.

Apply Click Apply to apply the changes you made in the TLP 
Receive tab.

Cancel Click Cancel to cancel the changes you made in the 
TLP Receive tab.

Help Click Help to display the online help.

Table 21 Components of the TLP Receive tab

Component Description
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Figure 20 displays the DLLP Receive tab.

Figure 20 DLLP Receive tab

Table 22 briefly describes the components of the DLLP 
Receive tab.

Table 22 Components of the DLLP Receive tab

Component Description

DLLP Types Click DLLP Types to display the DLLP Types dialog box. 
In this dialog box, select the DLLP type to which you want 
to apply filters from the Discard list box and move it to the 
Save list box. Once you have moved all the required 
DLLPs to the Save list box, click Apply.

DLLP Pattern Click DLLP Pattern to display the Pattern Editor dialog 
box. Here, select the pattern you want to receive, from the 
Select Pattern drop-down list. After this, edit its fields. 
Finally, click OK to apply the filter.

Trigger Pattern Click Trigger Pattern to display the Pattern Editor dialog 
box. Here, you specify trigger pattern for a selected DLLP.

Single Click Single to receive the data packet only once.

Continuous Click Continuous to keep receiving data packets for 
infinite time.
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Figure 21 displays the Receive Settings tab.

Figure 21 Receive Settings tab

Table 23 briefly describes the components of the Receive 
Settings tab.

Apply Click Apply to apply the changes you made in the DLLP 
Receive tab.

Cancel Click Cancel to cancel the changes you made in the DLLP 
Receive tab and to restore the original hardware settings.

Help Click Help to display the online help.

Table 23 Components of the Receiving Settings tab

Component Description

Buffer Specifies the maximum number of data packets that 
can be buffered in the TLP Receive tab.

Apply Click Apply to apply the changes you made in the 
Receive Settings tab.

Cancel Click Cancel to cancel the changes you made in the 
Receive Settings tab and to restore the original 
hardware settings.

Help Click Help to display the online help.

Table 22 Components of the DLLP Receive tab

Component Description
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To modify the settings for receiving TLPs

1 Click Pattern 1.

The Select a Pattern dialog box appears.

2 Click OK.

The Packet Editor dialog box appears.

3 Select the desired data packet template from the Packet 
Interface drop- down list.

4 Make changes to the selected data packet template details, 
as desired.

5 Click OK.

6 Select the Pattern 1 check box.

7 Select Discard for Pattern 1.

This ensures that data packets of the type you selected in 
the Packet Editor dialog box get discarded without going 
to memory.

8 Click OK.
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